Função PROCV() - procura na vertical

Observe a planilha a seguir. Temos valores na coluna A (que chamaremos de 1), valores na coluna B (que chamaremos de 2) e na coluna C (que chamaremos de 3).
A função Procv() serve para procurar um valor numérico ou texto na PRIMEIRA COLUNA e mostrar o valor que está na 1ª, 2ª, 3ª colunas (ou outras, se houver ).
Por exemplo, se procurarmos RTELL na 1ª coluna e queremos saber o que tem na 3ª coluna, da linha onde for achado o RTELL, teremos como resultado OUT.
Agora que você entendeu o "espírito da coisa", vamos entender a maneira de escrever e interpretar a função Procv(). Continue observando abaixo da figura a seguir.

Comecemos pelo exemplo da linha 19.

=Procv("rtell";A1:C10;3;Verdadeiro) significa:
Procure na coluna 1 a palavra rtell (observou as aspas? quando é texto elas são necessárias) para o intervalo que vai de A1 até C10. Depois veja o que está na coluna 3 e escreva nesta célula. (compare as cores para entender a fórmula)

Exemplo da linha 13:

=Procv(50;A1:C9;2;VERDADEIRO)
Procure na coluna 1 o valor 50 para o intervalo que vai de A1 até C9. Depois veja o que está na coluna 2 e escreva nesta célula.

Exemplo da linha 16:

=PROCV(80,2;A1:C9;3;VERDADEIRO)
Procure na coluna 1 o valor 80,2 ou o que for menor e mais próximo para o intervalo que vai de A1 até C9. Depois veja o que está na coluna 3 e escreva nesta célula.
Nesse caso a palavra VERDADEIRO, no final da função indica que o valor pode ser aproximado. Por isso vale o valor igual ou menor que 80,2. Assim foi encontrado 80,1 que é o menor e mais próximo valor do procurado 80,2. E na coluna 3 temos AGO.

Exemplo da linha 18:
=PROCV(81;A1:C9;3;FALSO)
Procure na coluna 1 o valor 81 exato (veja a palavra Falso no final da função) para o intervalo que vai de A1 até C9. Depois veja o que está na coluna 3 e escreva nesta célula.
Neste caso nada foi encontrado, gerando o erro #N/D, pois ao lançarmos o parâmetro Falso no final da função, exigimos que a busca fosse pelo valor exato. E não temos o valor exato 81.

Detalhe importantíssimo:
Quando estamos procurando valores aproximados - e, portanto, estamos usando o parâmetro Verdadeiro no final da função - a coluna 1 deve estar ordenada em ordem crescente ou alfabética. Senão o Excel ou Calc podem retornar valores errados. E também podemos substituir a expressão Verdadeiro pelo valor 1 e a expressão Falso pelo valor 0. O resultado será o mesmo.

 

Uma pequena diferença no Calc

Quando digitamos o parâmetro Falso ou Verdadeiro, no Calc, ao olharmos a barra de fórmulas veremos que a função ficou assim:

=PROCV(81;A1:C9;3;1) - quando for verdadeiro
=PROCV(81;A1:C9;3;0) - quando for falso

Ou seja, você pode usar a palavra Verdadeiro ou o valor1 ou a palavra Falso ou valor 0.

E se o valor procurado estiver em outra planilha?

Exemplo: Desejamos ver na Planilha da esquerda (Plan1), na célula A1, o telefone da Márcia que está na outra planilha, a da direita (Plan2)

A função em Plan1 na célula A1 deverá ser:

=PROCV("Márcia";Plan2!A1:D6;4;FALSO) - veja na Barra de fórmulas.

Assim, a célula A1 retornará o valor do telefone da Márcia.

..............................Plan1...................................................................

 

. ...........................Plan2


Sua vez! Não fique aí parado; experimente!


Função PROCH() - procura na horizontal

Todo o raciocínio seguido acima vale para a função PROCH( ). A diferença aqui é que a busca é feita na horizontal e não mais na vertical.


Podemos ler a função acima assim:

Sr. Excel, procure na Horizontal a palavra Ana no intervalo que vai da célula B1 até à célula H8 (observe o retângulo azul). Quando o Sr. achar a Ana veja o que está escrito na linha 6. A linha 6 é a 6ª linha de cima para baixo, incluindo os nomes dos alunos.

O Sr. achou 9? Perfeito!

Agora é sua vez, Sr. Concursando. Experimente!

 

 

-->